Forum Index » General Support » Jabra Node.JS not compatible with MacOS 10.10   XML
 
Author Message
ChristianDK


Joined: 23/07/2018 03:16:27
Messages: 3
Offline

The binary library libjabra.dylib included in the distribution is only signed with SHA-1256, making it incompatible with MacOS 10.10.


I guess I can sign it using my own certificate, but it seems it would be easy for you to add a SHA-1 signature to the official release, so I think this would be a better solution.


The issue is explained here: https://stackoverflow.com/questions/41865537/how-does-apples-codesign-utility-decide-which-sha-algorithms-to-sign-a-shared


JabraJohn1


Joined: 23/04/2018 04:54:57
Messages: 52
Offline

thanks for the post. yes we are aware of this and the next release of the node.js sdk will have this issue fixed.
 
 
Go to: