Forum Index » Browser development » Detecting multi-function button / Odd ring command behaviour   XML
Author Message

Joined: 17/04/2018 04:27:59
Messages: 0

Very excited to use your new websocket interface with our browser voip app. It's exactly what I'm looking for.

Installed the msi and I can send commands to the jabra client and it responds but I have two questions:

1. When I send the ring command, it only rings 2 1/2 times and then stops. 'getState' then returns 'incomingCallState:true'. When I then send the 'stopRing' command, it rings once again and sets 'incomingCallState:false'. This seems odd behaviour. I would expect it to continue to ring until I command otherwise. What am I missing?

2. I need to detect the users clicking of the Jabra multi-function button... but on clicking I get no message. From 'usage' I'm seeing the response 'AcceptCall' and 'RejectCall'. I would expect to see these on clicking the button, but as noted, get nothing. Again, what am I missing?

(I am testing with the Jabra 930)

Joined: 17/04/2018 04:27:59
Messages: 1

Hi Richard,
good to hear about your usage.
1. Ok I just tried your ring observation using the demo test client which is included in the Websocket package, and the device kept ringing. Can you please try using the demo client?
2. Ok can you try this scenario with the demo client as well. I tried it and it seems to work fine. So when you send a 'ring' and press on headset multi-function button, this will translate into 'AcceptCall' which should be acknowledged by your app with a'OffHook'signal.

Look forward to hear from you.

Go to: