Forum Index » General Support » Jabra new sdk 1.10.0-3904.beta crashes when a jabra device attached in Electron 3   XML
 
Author Message
zhangzf



Joined: 30/12/2018 16:18:39
Messages: 1
Offline

Dear developers,
First of all, Thanks for the new SDK.

I followed the instruction at this page: https://www.npmjs.com/package/jabra, it compiles and runs as normal.

But If I attached a device, Evolve 75 here, the app will crash, even if I did some try catch.
If the device is attached already, it crash at the start.


I made a sample project, please take a look and have a test, Thanks again.

https://github.com/fangzhzh/electron-react-boilerplate

± % python --version
Python 2.7.10
± % node -v
v8.11.3
± % uname -a
Darwin 18.2.0 Darwin Kernel Version 18.2.0: Mon Nov 12 20:24:46 PST 2018; rootsmilienu-4903.231.4~2/RELEASE_X86_64 x86_64




I did some trace, it crashes at ~/workspace/electron-react-boilerplate/node_modules/ffi-napi/lib/callback.js, ```debug('Callback function being invoked')```
it looks to me a bug related to node-ffi-napi callback

https://github.com/node-ffi-napi/node-ffi-napi/issues/17

I hope this helps

This message was edited 2 times. Last update was at 30/12/2018 18:05:01

 
 
Go to: