Messages posted by: Joseph
Forum Index » Profile for Joseph » Messages posted by Joseph
We got your SDK working OK on our Skype for Business client on RHEL and SUSE.
It fails on RHEL 6.
I have a big customer still on RHEL 6.
But they will eventually upgrade to a newer RHEL version.
MORE IMPORTANT: I need a solution that does not require user to rebuild his OS. It's a very bad requirement.
My status is: We had success on SUSE, and plan to fix final bugs on SUSE next week.
After we release on SUSE, we will test on Red Hat, Ubuntu and Debian.
Then I hope Jabra will submit to the Linux kernel. It is very important, to avoid forcing users to rebuild their OS.
Hi Mehmet,

We are working to finish this project now.

I checked the Headset API on openSUSE 42.1: No root is required, but I only get offhook signal when I press on Jabra 930 with sdk (
I cannot get all signals like in the Jabra user guide document (HEADSET MULTI-FUNCTION BUTTON):
How can I get all these signals?
I also tried on Jabra 950. Seems like your SDK does not work on the 950. Which headset do you recommend for this?
Sorry, my mistake, my headsets are 930 and 510
510 firmware: 2.10.0
I bought Jabra Biz 2300. It works. I can catch signals from the call button and hold button.

By the way, this forum shows oldest message first. It's an annoying method.
When did you submit your patches to the Linux kernel. Do you know when they are scheduled for inclusion in the Linux kernel?
When you submit to distros for inclusion in kernel, please keep in mind these distros:
Fedora/Red Hat, openSUSE/SUSE, Debian/Ubuntu

Fedora is leading distro for all Linux, so I suggest that first.
openSUSE is leading distro for SUSE SLED.
Debian is leading distro for Ubuntu.
I created a rule like you said above: /etc/udev/rules.d/99-myhid.rules

Then, I can run test program without root permission, but I only get 1 signal
"0x00: Off Hook: 0"
when start testing program,
then no signal appears if I press any button on headset.
Another problem:
I only get 1 signal: 0x00: Off Hook: 0 when start program,
then I don't get any signal although I press any button
Good, I created this configuration, and no root is require to run the module.

But, the program always crashes if this udev configuration not found.
Some users do not need this module, so do you know how to fix this issue?
My Linux for Lync app can catch headset signals now. That's good.
I can only catch signals from the headset when I run the app in root permission.
This problem happens on both: My Lync app and your Jabra test sample program.

My customers won't want to run it in root. Please find a solution for this.
Yes, it works on OpenSUSE LEAP 42.1 with firmware version 2.23 and their Native API Test program.
My device (Jabra Pro 930) firmware is 2.4.0
Which OS did you test? I try on OpenSUSE Leap 42.1, but I cannot catch any button button signal from headset in sample program. How do I know my Jabra device version?
I only see under device:

Model: WHB003BS
SKU No: 930-65-503-105
Forum Index » Profile for Joseph » Messages posted by Joseph
Go to: