Messages posted by: Richard3
Forum Index » Profile for Richard3 » Messages posted by Richard3
Device manager after boot:
Jabra direct dashboard after boot:
Jabra direct dashboard after unplug usb: (same)
Jabra direct dashboard replug usb:

Hi Mehmet,

On boot: Jabra direct status is 'No devices connected'
On unplug usb: same
On re-plug usb: 'Device ready for use'

Is that what you mean?

I also looked in the device manager. It shows the Jabra Pro 930 present and 'functioning normally' for both speaker and mic.

Hi Mehmet,

Updated to 1.1.13279.

Same result.

smilie Richard.
Hi Mehmet,
We have a solution using the JABRA Websocket SDK that has been with clients since the start of the year. Till now, all good.

But currently we have a customer whose install can't detect their headset on first try. If they unplug the headset from their pc, then reconnect, the sdk will then detect it so the problem does not appear to be with our code but with the sdk.

We are using version 1.0.10247.0 of the sdk. The pc is a new windows 10 dell i7.

Do you have a fix for this? If not, how can we troubleshoot this problem.

Hi Mehmet,

Well that is a totally disappointing answer. Our software is deployed b2b, not as part of enterprise infrastructure so expecting our clients to generate and install a certificate on their machine is laughable.

I was excited for your initiative to enable web socket access to your headsets... but now when it comes to a real-world application and not just a demo, the details make it impractical.

Is that the best you can do?

When I send the mute signal to the headset, GetState response does not change. What is the purpose of HoldState in the GetState response?
Cool Mehmet. I look forward to it.
smilie Richard.
Can you give some documentation on using secure websocket connection to the Jabra websocket service? My use case is I want to connect from the local browser to the locally installed service.

I see you can specify the certificate thumbprint at installation time. But what should this thumbprint be?

I tried just using wss: but that didn't work.

Please give detailed steps so I can get this working. As you probably know, browsers will block non-secure ws connections from a https page so this is critical to a useful real-world application.
Very excited to use your new websocket interface with our browser voip app. It's exactly what I'm looking for.

Installed the msi and I can send commands to the jabra client and it responds but I have two questions:

1. When I send the ring command, it only rings 2 1/2 times and then stops. 'getState' then returns 'incomingCallState:true'. When I then send the 'stopRing' command, it rings once again and sets 'incomingCallState:false'. This seems odd behaviour. I would expect it to continue to ring until I command otherwise. What am I missing?

2. I need to detect the users clicking of the Jabra multi-function button... but on clicking I get no message. From 'usage' I'm seeing the response 'AcceptCall' and 'RejectCall'. I would expect to see these on clicking the button, but as noted, get nothing. Again, what am I missing?

(I am testing with the Jabra 930)
Forum Index » Profile for Richard3 » Messages posted by Richard3
Go to: