Messages posted by: Lukas2
Forum Index » Profile for Lukas2 » Messages posted by Lukas2
Message
Hi Natascha,
I can share my experience regarding the pure HID API based integration with Jabra Pro 9460 (which can be quite similar to your 9470).

1. Install Jabra Chrome HID SDK (V1.1.0) just to see how it may work.
For more low-level approach in C a simple example from Linux kernel can be used - http://lxr.free-electrons.com/source/samples/hidraw/ (change device identification, compile and run -> at least the HID descriptor and vendor/device ID should be printed)

2. Try to decipher the HID descriptor - http://eleccelerator.com/usbdescreqparser/ or RDD https://github.com/abend0c1/hidrdd can be used

3. Read everything about Jabra HID API - Windows SDK documentation contained some additional info, Chrome plugin in JavaScript is quite readable and had some other info if I remember correctly.

Hope it helps,
Lukas
Hi Mehmet,
Is there something new regarding the updated firmware for Jabra Pro 9400 series?

Kind Regards,
Lukas
I think this is mentioned in the SDK documentation.

In my case I have a rule in the udev configuration that allows all users in the "users" group to access all Jabra devices:

cat /etc/udev/rules.d/99-myhid.rules

<code>ATTRS{idVendor}=="0b0e", MODE="0660", GROUP="users"</code>
Thank you, looking forward to the new firmware.
Hi Mehmet,
I have a Jabra Pro 930 MS and it reports some events (off hook, flash, mute). Is there any known issue related to this model with the latest firmware 2.23?

Can you please share the expected release date for the new firmware for Jabra Pro 9400 series? If the date is not known yet then at least some rough time frame (is it couple weeks or months?) would be helpful in order to adjust our expectations.

Thanks and Regards,
Lukas
Hi Mehmet,

Jabra Pro 9460 changes its state after pressing the off hook button in the test application (0 changes to 1 on the off hook button). To be more specific, it opens link between base station and headset and this is indicated on the base station display and audio feedback between microphone and speaker can be heard. Pressing the off hook button again reverts it to the previous state and beep can be heard.


There are data from the kernel ring buffer and output from your testing application. The scenario was the following:
1. connect Jabra
2. start the testing application
3. press the off hook button, check the device state
4. press the off hook button again
5. exit the testing application
6. disconnect Jabra

<pre><code>
kern :info : [399369.760627] usb 2-1.2: new full-speed USB device number 21 using ehci-pci
kern :info : [399369.851639] usb 2-1.2: New USB device found, idVendor=0b0e, idProduct=1041
kern :info : [399369.851648] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
kern :info : [399369.851652] usb 2-1.2: Product: Jabra PRO 9460
kern :info : [399369.851656] usb 2-1.2: Manufacturer: GN Netcom A/S
kern :info : [399369.851660] usb 2-1.2: SerialNumber: 0280F7BFF006
kern :info : [399369.876069] input: GN Netcom A/S Jabra PRO 9460 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.3/0003:0B0E:1041.0096/input/input165
kern :info : [399369.876478] hid-generic 0003:0B0E:1041.0096: input,hiddev0,hidraw4: USB HID v1.00 Device [GN Netcom A/S Jabra PRO 9460] on usb-0000:00:1d.0-1.2/input3

MainWindow
JabraFirstScanForDeviceDoneFunc
OnFirstScanDone
JabraDeviceAttachedFunc deviceID= 0 , productID= 4161 , versionNumber= 0 , deviceName= 0x7f8924000af8 , usbDevicePath= /dev/bus/usb/002/021 , partenInstanceId=
OnDeviceListChanged
UpdateDeviceListBox
UpdateButtonStates
GetSelectedDevice
on_m_HookButton_clicked
GetSelectedDevice
GetSelectedDevice
GetSelectedDevice
GetSelectedDevice
UpdateButtonStates
GetSelectedDevice
on_m_HookButton_clicked
GetSelectedDevice
GetSelectedDevice
GetSelectedDevice
GetSelectedDevice
UpdateButtonStates
GetSelectedDevice
on_exitButton_clicked
~MainWindow

kern :info : [399460.054427] usb 2-1.2: USB disconnect, device number 21
</code></pre>


Are there any other specific logs that would be helpful?

Best Regards,
Lukas
Hi Mehmet,
Thank you for your reply.

The device was removed before taking the screenshot on Windows, so the device information are missing.

There are no data in the input / translated box, no matter what I try to do with the headset or which button I press in the application.
On the other hand, pressing the Ringer button generates a ringtone on the base station.

I have upgraded the firmware version to 3.19.2, but the results are the same.

Would it help if I send you some logs from my machine?

Best Regards,
Lukas
Hello,
I am trying to add support for Jabra PRO 9460 to our Linux application.

I have followed instructions described in SDK the documentation, patched and built kernel, but function of the test application seems to be limited. I am not sure if it is feature or bug.

So this is how it looks on Windows after pressing Ringer button in the application:
<img src="https://jabra.wpengine.com/wp-content/uploads/rtMedia/users/1057/2016/04/Jabra9460HIDAPITest-Win.png" alt="Windows" />

Whereas in Linux, the window looks like this:
<img src="https://jabra.wpengine.com/wp-content/uploads/rtMedia/users/1057/2016/04/Jabra9460HIDAPITest-Linux-800x499.png" alt="Linux" />

There are no Raw Hid data and no Translated data.
Ringing works in both Windows and Linux.


OS openSUSE 13.2 (Harlequin) (x86_64):
<pre><code>
cat /proc/version
Linux version 3.16.7-35-desktop-gncustom (root@rypl-ntb.marconi.ttc.cz) (gcc version 4.8.3 20140627 [gcc-4_8-branch revision 212064] (SUSE Linux) ) #1 SMP PREEMPT Thu Apr 21 17:09:51 CEST 2016
</code></pre>




Is this expected state or does it indicate problem on my side?

Thanks and Regards,
Lukas
Hello,
The search function in Jabra developer forum seems to be searching in forum titles only. This has quite limited usefulness. Would it be possible to search in posts content as well?

Thanks and Regards,
Lukas
 
Forum Index » Profile for Lukas2 » Messages posted by Lukas2
Go to: