Messages posted by: sten@jabra
Forum Index » Profile for sten@jabra » Messages posted by sten@jabra
Yes, you are correct. The SDK USB library is checking for updated device protocol manifests from
I can see now how that hampers the device scanning, as the USB library checks for updates before scannning.
Thanks for letting us know!
Test message (user is experiencing problems replying to the thread.)
Ok, sorry to hear.
While we don't have your motherboard to hand, we have created a task to make in Ubuntu installation to see if we can reproduce.
When you say you don't need the full integration, does this mean you are using the SDKs on Windows and they work for you?
Hmm. It should work out of the box with the normal USB subsystem for audio devices.
What device are you using?
Have you tried other USB ports on the device?
What distribution are you using, what version?
I am using a WebRTC on macOS with Engage 75 and was wondering if it is possible to control aspects of the headset using AppleScript (or Automator), specifically “Off Hook” so I can fire it whenever I am on call for the purpose of handling other incoming calls from a mobile device connected simultaneously to the Engage 75.

Any idea is appreciated, thank you for your help.

Can you clarify the following:

> I am using a WebRTC on macOS

A WebRTC app? From within a Chrome browser?
Then you can use the Browser SDK to issue an off-hook command to the headset.

I would also ask if you can explain a little more about what you are seeking to achieve with this.
Are you expecting to pick up the second call while the first one is ended, but without pressing the multi-function button on the headset?
Then you may need to hang up the first call first, and that is not controlled by the headset, but the softphone application that is managing the first call.
Telling the headset to hang up will bring it out of synch with the other application.
Is it really looking for SSL 1.0.0?

Yes, I'm afraid it is.
The dev team tells me it's quite likely a depency from libcurl, which is statically linked into the library.
The library has been tested and verified on Ubuntu LTS 16.04 and 18.04 - this is what we pt officially support.

Again, can you share more details about what you are building and what for, we may get more leverage with product management in prioritising development effort.
(If you are concerned about confidentiality, feel free to register and create a support ticket - this can only be seen by you and us.)

sorry, missed this one.
No, the initial scan should take a second or two, max.
Same for Jabra Direct.

What other USB devices do you have attached to the system?
No, sorry, there is no way of getting caller ID from device library.
This is up to the softphone to decipher from the calling stack.

Also, there is currently no way of displaying caller ID on devices with displays, such as the Enageg 65/75 bases.

sorry, no, we do not have an RHx compatible release on the roadmap.
It's currently Ubuntu, and derived distros.

But please provide us with a need/use case for this, and we can use it to feed Product Management into prioritising this.
(ie. tell us you need it, and especiialy what for smilie

Hello, and thanks for posting.
Yes, the document you have is still valid.
For any support issues do register if you haven't already, and post a ticket.
Update: while we did update the SDKs for Windows, Mac and Linux around Christmas time, and have recently updated the adapters for the Chrome browser and node.js operations, we regret to inform that the iOS and Android SDKs now have no specific horizon.
We are looking into other ways of integrating with Jabra devices on those platforms, and will advise when we have more clarity.
First: Have you tried registering a ticket with Jabra product support? (
That is the official channel for product support (whether it's the Engage 75 or the Direct).

But they will probably also ask you questions like:

  • when the crash happens, is it during usage, or just with Direct running in the background?

  • does the engage 75 failure this also happen when *not* running Direct (you don't *need* Direct to just use headset in normal usage, unless you need the "preferred softphone" option to prevent clashes).

  • are you up to date to the latest Direct version (and headset FW?)

  • if you do need to adjust settings and the like with a running app, you can also try the demo-app in the SDK for Mac. This provides settings access to most of the stuff you can do with Direct.
    The demo app and Direct both use the Jabra core libraries to interface with the device (this is where the stack traces are from, not actually Direct), and might provoke similar errors (although there can be difference in the version of the core lib used).
    Hi, and welcome to the forum.

    While I don't know the specifics of PopOS, it does very much seem to a problem with the audio routing in the OS, rather than the device.

    Are you developing an app to use the device, or is this a general operations issue?

    I would suggest you try something like the following (I can't tell you whether this is applicable, though, as I don't have any experience with PopOS).

    If you still can't make it work, it could be a product issue. If you have the possibility to try out on a Windows machine (eg. borrow one), you can check if the device works.

    For product specific support, you can go to and raise a ticket.
    > Yes, It's a two years issue you still haven't answered.

    Ok.But you also have a ticket in the support system registered with a lot more information exchanged.
    I will re-open that ticket and continue the support dialogue there.
    (We can update this thread once we found a solution).
    This forum is for developers and integeration partners.
    You need to ask product support at
    Forum Index » Profile for sten@jabra » Messages posted by sten@jabra
    Go to: